Potřeboval jsem nainstalovat server, o který bych se nemusel moc starat. Prostě jenom semtam spustit něco na stažení updatů a na to se Gentoo z pochopitelných důvodů moc nehodí. Takže první test padnul na Ubuntu. Apt-get trochu znám z Debianu a je povedený, balíčky jsou aktuální, zkrátka vyhovuje objednávce. Z Gentoo jsem si perfektě odvyknul jakýmkoliv pokusům o instalátor, v podání Ubuntu se mi to ale vrátilo jako instalační teror.

Prvním pokusem jsem se nedostal ani k rozdělení partition. Instalátor prostě umřel někde u detekce disků a odmítal reagovat, pomohlo až zabít jeden z jeho procesů z konzole.

Druhý pokus byl úspěšnější, dostal jsem se k partitioneru a byl jsem zvědavý jak si poradí s mým přáním. Ve stručnosti:

  • Všechny partition na RAID1 s chybějícím diskem
  • XFS naformátované s určitými parametry (velikost logu a inode)

Hned vidím nějaké zmínky o RAIDu, tak zkouším jak to půjde. Červená obrazovka není dobré znamení, prý mi chybí partition. Samozřejmě že chybí, o missing na místě označení partition ale instalátor nikdy neslyšel. Hledám dál, ale situace je jasná, dodej dvě partition, jinak se s tebou nebudu vůbec bavit. Zkouším jestli to nepůjde jinak, skáču opět do konzole a přemýšlím, k čemu ten instalátor vlastně je. Už první pohled naznačuje, že komfortní prostředí ala Gentoo mě tady nečeká. Chybějící barvičky jsou jenom maličkost oproti chybějícímu less, man nebo screenu. A cfdisku……. Zaskřípu zuby a jdu si osvěžit pamět s fdiskem. Neexistující zařízení /dev/mdX jsou očekávaný problém, mknod se ale naštěstí nikam neztratilo. Takža RAID pole jsou vytvořené, pro jistotu je ještě naformátuju a vracím se zpátky. Zatím je skóre špatné……..
Instalátor je z mého počínaní trochu rozladěný, cítí se zbytečný a rozhodne se mi to vrátit. Takže sice si všimne existujících polí, už ale nevidí filesystémy v nich a pořád dokola mele, že tam žádné nejsou. Zkusím se třeba podívat jestli mu jenom nechybí mountpoint, což by bylo vcelku logické, ale mám smůlu, „not use“ mluví samo za sebe. Pokud vyberu XFS a vyberu mu mountpoint, tak se instalátor rozhodne, že pole přeformátuje znovu (asi mi nevěří). Zkouším najít kde bych mu třeba mohl zadat nějaké parametry, ale je to marné, druhý požadavek mi nikdo nesplní a XFS budu mít se standardními parametry. Už se tomu ani moc nedivím, pravděpodobně jde o nějakou betaverzi. Jak to ale bude fungovat s chystanou podporou SELinuxu, kde je důrazně doporučeno formátovat XFS s většími inodes netuším, snad to vývojáře napadne. Znechuceně nastavuju všechno znovu, spouštím instalaci a jdu napsat tenhle post. Skóre je velice špatné……..

Instalátor nakonec zamrznul v dalším kroku při 17%. Po instalátoru FreeBSD, který byl totálně zmatečný a nepřátelský si začínám říkat proč je lidi vlastně dělají, když je neudělají pořádně

O Ubuntu si jinak myslím, že jde o skvělou distribuci, kterou dokážou používat i moji rodiče a to je co říct. Semtam se ale prostě něco nepovede. Vyplnil jsem odpovídající bugy, snad se něco změní.

Zanechej komentář

K zanechání komentáře ke článku musíte být přihlášen. Přihlásit »